MakerBot Connection Issues [SOLVED]

Just upgraded to the .6 firmware with MakerBot/X3G support, but my connection to the printer isn’t working- the box recognizes the Replicator 2, but in the ‘settings’ tab, the connection is stuck on the ‘loading’ dialog. I’ve tried wiping and re-installing the SD card, re-installing the firmware via the AstroPrint dashboard, changing to a more powerful power supply, and power cycling both the printer and the box. When I first start the box, the printer makes the startup sound, so I know that the box can somewhat communicate. When I try to start a print, the error message reads: “The printer is not responding, can’t start printing.” I’m using a Pi B (not b+) and a Mac.

1 Like

I have the same problem. I didn’t upgrade the firmware since a couple weeks ago but it says “connecting…”. I emailed support and they said under settings>printer>profile to change the driver to x3g. But there is no driver option. Updating pi to .6 now. look for the driver type for x3g and try again.

Just re-installed and I’m trying the setup again. The ‘Connect Your Printer’ part of the setup is taking a while; I’ll wait for a few minutes and see what happens. I do have X3G selected, and when I booted the Pi the Rep 2 restarted- hoping it’ll work this time.

Still not working. Connection is taking way too long (around 10 min and still going.) Maybe it’s a firmware issue on the MakerBot- I’m running 7.6. Anyone have their Rep2 working, and if so, what’s your firmware version?

Keep in mind that we have developed and tested this using a Flash Forge Creator Pro (Makerbot clone) but we did have other people test on Makerbots and other Sailfish based printers.

I don’t know about specific software versions.

I believe that @Noe_Ruiz was successful with a Rep2.

@Josh1 @Samuel 0.6(0) is the first release with support for SailFish. Earlier versions didn’t know how to speak to the printer so it won’t ever connect.

Also when you get 0.6(0) remember to set your driver to X3G during setup or later going to Settings->Printer->Profile.

Somehow another connection issue here.
On my CTC the setup works great. Everything as expected. In the control tab everything works!
BUT:
If I upload a x3g file and try to print it, astrobox looses the connection to the printer and nothing happens.
The CTC wants to start the print (The screen even changes to the Heating-Monitor-Screen with the filename displayed) but then it stops.

CTC shows just current temperatur not the should-be-temp. (e.g. “Platform 43C” instead “Platform 43/110C”)

After some time the print is canceled(?) and I can start from the beginning.

File was sliced with Simplify3D.

Update:
When using the astroprint slicer (cura) everything works except the heated buildplate doesn’t heat up. Extruder in fact is heating up.

@Spiernik would you be able to put the X3G file that fails in Dropbox or drive and send us the link. We’d love to try her and debug.

You can private message me or use our support system at https://AstroPrint.zendesk.com

I’ll update the results of the investigation here.

I have the first Beta 1 (AstroBox-rpi-0_6_0-20150327) running great with Rep2 on firmware 7.5.

My college tried Beta 2 (AstroBox-rpi-0_6_0-20150410) on his Rep 2 (fw 7.5) and had very similar connectivity problems like @Samuel and @Josh1 . We couldn’t get it to connect after an hour of attempts.

Switching back over to beta 1 worked right away tho!

1 Like

Thanks @Noe_Ruiz. Can any of you set the serial logging on ( https://astroprint.zendesk.com/hc/en-us/articles/203828935-Debug-Serial-Connection-to-Printer ) and send us this file after an attempt to connect?

/var/log/astroprint/serial.log

Reporting on the progress for @Spiernik’s problem. It turns out that Simplify 3D has a bug by which they issue a Build Start Notification command using the filename as the build name. This sometimes causes the package length to go over the 32 bytes maximum specified by the S3G protocol.

Our implementation would choke and stop at that error. We have now made a fix that gracefully logs a warning when this happens and continues the print. I was able to print the file that @Spiernik sent me after this fix.

Expect a 0.6(1) very soon with this and the makerbot connection fixes.

2 Likes

Awesome!
Have thought so, that it’s a problem between Simplify3D and Astroprint.

Good to know you guys are working really quick!

When is the new .6(1) firmware expected?

I need Makerbot logs and testing on an actual Makerbot. We’re trying to get access to one here.

I would expect the release by end of the week. If anybody can help by sending logs, it could accelerate things.

Hey Daniel - I downloaded the image 0.6(0) for my own Raspberry Pi last night. It flashed to SD fine. Loaded fine and I actually got all the wifi work done so it connects wirelessly to my home network. But it stays in “Connecting…” status forever when it tries to find my Replicator 2 (running Sailfish). I tried to ssh into the Pi from terminal on my Mac so I could help out with log files. The first thing it asks for is a password. Any thoughts on which password it wants? I haven’t changed it if that helps. If I can get in, I’ll send you the log files.

We don’t change the raspberry pi default password so:

Username: pi
Password: raspberry

Good News! The problem has been solved and a new release as been posted.

Please update your boxes to 0.6(1) and you should be able to connect to your Makerbots. Thanks everybody for your patience.

1 Like

Daniel - the Download link still only shows 0.6(0). Where is (1)?

There’s no need to recreate the sd card. Simply update your software from the settings menu

Not sure where you mean. this is only my second day poking around…