Nozzle then bed heating order


so, I am still struggling with Astroprint, but I sort of initiated a print from the cloud yesterday. I dislike the heating order. The nozzle heats, then the bed. I’ve had 100% success with adhesion on a clean, heated bed, so I’m not stopping heating. BUT, the nozzle sits and oozes while the bed heats. This means that my nozzle oozed on my bed electrical connection, and then when the print started, there was a tail of PLA on the bed that was drug around by the nozzle for a while, causing my skirt to lift.

Also, when cancelling a print, could you make it so it cancels the print, THEN asks its brief survey of why…

Any way to change the heating order?


You can edit your start gcode in the printer profile advanced settings at Once you do that, you need to delete your print file so that it gets re-sliced with the new start GCODE.


wow, Astroprint is more complex than I thought… I googled this…from the Simplify 3d site…is this correct? So I would have to change the variables in here, manually if I wanted to manipulate any temperatures?

M140 SX ; start heating the bed to X degrees Celsius
G28 ; home all 3 axes while the bed is still heating
M190 S X ; wait until the bed reaches X degrees before continuing
M104 S Y T0 ; start heating T0 to Y degrees Celsius
M109 S Y T0 ; wait for T0 to reach Y degrees before continuing with any other commands


Hah, or you could say that astroprint is flexible. We give you a default and let you change if it doesn’t fit your needs.

Which is your printer?


good point. I have a CR-10S