Raspberry Pi Camera Support [SOLVED]


#21

Hey Daniel, I just want to make sure I am clear. Raspicam is supported in stills but not video, correct? I can get stills to work, but I cannot get video to work.


#22

Video in Chrome 56 is broken for some reason. Video with the raspicam is supported and should work on FireFox, older Chrome version and hopefully future ones too


[SOLVED] Unable to start the WebRTC system video streaming?
#23

Here is something strange that I don’t understand. Using pi camera v2, I can view video or snaps on my Mac and Samsung pad using Firefox. But when I try the same thing on my iPhone or iPad, it tells me I am using Safari and it’s not supported even though I am in fact using Firefox. Same thing happens when I try google chrome. Any ideas?


#24

Firefox ( or chrome ) in iOS still uses the safari engine underneath. It’s a limitation of iOS


#25

So I can’t do this on an iOS device? Wow…


#26

That is correct @John_How Apple is still working on their webRTC support. Not really something we can help with.


#27

I had some issues and had to reflash my SD card. I then had to set up the raspicam inside Astro box. This took me forever to figure out.
The bit about how to log into your astrobox to run raspi-config (for noobi’s and idiots like me) should definately be included in the setup instructions. For me on a mac, it was so simple once I found out how. Just ssh pi@astrobox-xxxx.local. PW "raspberry"and run sudo raspi-config… but I did not know. So please include in setup instructions and just say ignore if you don’t have a camera.
Thanks and sorry bout the soapbox attitude…


#28

For noobs the raspicam is quite complex and we discourage it


#29

It was a piece o cake when I found the simple answer…


#30

Hi john, can you help me with the steps??

Regards,

FA


#32

Hi FA, the way I did it is hook my mac up to the pi with a network cable. Open a terminal window and type the following.
ssh pi@(astrobox name).local
The password should be (raspberry)
After your logged into the pi, type
sudo raspi-config
You will see a menu of things to do, one of them is to configure peripherals so you should select that and the one of those selections is to enable the camera. Do that and then close the menu using the selection at the bottom of the menu and you should be good.
When your back in astroprint go to the setup menu and look for the camera setting to enable and detect it.
If your using a PC then the procedure is the same but you need some other software to do the “ssh” and I’m not sure what that is.
Hope this helps…


#33

Ok so I am using latest (at the time of writing 4.4.2018) astrobox soft, enabled camera, ssh, spi, i2c in raspiconf, then modprobe bcm2835-v4l2 and pi camera is still not detected. It happens so fast I doubt it is even trying to detect it. No lights on camera as well. FAQ, despite what was mentioned about updating it here, does not mention pi camera.

any help is appreciated


#34

I managed to get it to detect camera however no image is streamed. At any resolution. Still ‘loading’


#35

I just hit the same issue with latest AP on a RPi Zero W. Camera is detected, but it doesn’t get past the “preparing video” message, accessed from firefox on windows. No solution to this?