Raspberry Pi Camera Support [SOLVED]


#1

Has any body been able to successfully install the needed drivers and kernel to use the ribbon cable Pi Cam as the Astroprint video camera? I really want to be able to use the camera and mount I have stuck to my Makerbot Dual Extruder already. :smile:


Camera Support for Pi
#2

If it’s the same as with raspian, all you should have to do is run sudo raspi-config and enable the camera through that menu.


#3

hi,

i have installed the drivers for the camera.
i can make pictures and videos via the console interface, but in the software ist doesn’t working.

i need some help on these but not so firm with raspian, i’m learing these language.

greetz


#4

Same problem here as well, I thought it would work with the standard Pi camera!


#5

Any updates on this? I would like to try out AstroBox on my RasPi with the RasPi camera.


#6

I have nearly got this to work using the v4l drivers for the raspberry pi camera.

If you have the latest updates for the Raspberry Pi, all you should need to do is run:

sudo modprobe bcm2835-v4l2

Then restart astrobox

sudo /etc/init.d/astrobox restart

This is about as close as I have been able to get it to work.
The only existing issue is that the image is captured at 16 x 16.


First Print - Rostock Max V2
#7

Did you have to install the bcm2835-v4l2 driver or was it already in the latest software? We can make driver loaded by default on boot for the next release.


#8

I think they are included with the latest software. I will test it again to be sure and let you know.


#9

Just tried it with AstroBox-rpi-0_5_2-20150209.
The drivers are pre-installed.

You do need to run:

sudo raspi-config

And enable the camera.

The 16px x 16px resolution is still a bit of a problem. But the camera does technically work.


#10

Okay I haven’t got a chance to try this with AstroPrint yet. But it fixed my gstreamer raspberry pi camera issue in another project i was working on. this may fix the 16x16 pixel image.

Try starting the camera driver with this:

modprobe bcm2835-v4l2 gst_v4l2src_is_broken=1

This may be the final step in getting the Pi Camera to work.

Once I finish up my project and get a chance to put my AstroBox image back on my Raspberry Pi I’ll try this there.


#11

Any reports on wheter this Work, or?

The raspeberry camera working is the GO or NO for me, so rather important.


#12

Yes the Pi camera is now supported. Make sure the software is updated to the latest release.


#13

Great news. Probably a good idea to update the FAQ’s to reflect this.

cheers,
c


#14

@vandal968 Great catch! thanks for the heads up. It is now updated :slight_smile:


#15

Sorry for replying to an old thread but I have a problem with my raspi cam. I have v0.8 installed and can get it to work by running the modprob command but if I reboot the pi I have to issue thcommand again. Isn’t this latest release of astro supposed to take care of that?


#16

@Troy_Williams Have created a new sd card with 0.8? or just updated the software over the air? You would need to create a new SD Card for this fix.


#17

I just updated from an older version. I did get ti to work however by adding the modprobe command to the modules file.

I may re-create a new SD card soon to clean up some of my messing around.

Thanks


#18

Yes, that’s what the new image would have done for you.


#19

New here, just installed AstroBox-rpi-0_9_0-20160602, updated through the webapp but Astroprint can still not find raspicam. This command ‘raspistill -o cam.jpg’ works so I know the camera is working anything else I need to do?


#20

Please read this: Update to 0.9 not offered