[SOLVED] BCN3D Sigma support


#1

Hello,

I just finished setting up an Astrobox for my BCN3D Sigma printer and just saw that it won’t connect to it.
The printer is based on Marlin.

Any tips on how to make it work?

Thanks

Mauro


#2

Play around with the baud rates. We have a BCN3D R working at the office


#3

I did.
I tried all baud rate options but no dice.
The printer apparently uses a FT232 USB-Serial (UART) IC chip for connection.
Is that supported?

Thanks


#4

Same here.

I tried all the baudrate without success. Previously I used Octoprint with the BCN3D Sigma and it worked well ! Please Astro Team, provide support for the Sigma :wink:


#5

We would need help as we can’t possibly buy all printers in the market. One way to you can help us is by activating serial logs and sending it to us. Another way is by contacting BCN3D and letting them know about this.

If the printer has a standard version of Marlin, there’s no reason why it shouldn’t work


#6

I activated the serial log but the log directory stay empty…


#7

It’s ok, I just send you the log :wink:


#8

I can see from the log that the right baud rate is 250000.

It’s looking like the printer is taking too long to respond to the ping M105 command. I’m moving some things around for the next release to try and prevent this. However you can try manually increasing the communication timeout to see if it would work. It’s currently set to 8 secs.

Edit the file /etc/astrobox/config.yaml and add the following lines:

serial:
  timeout:
    communication: 20

then save and restart the service sudo service astrobox restart

Let me know if 20 is enough to get the printer respond and detect the connection.


#10

Ok, I succes to connect to SHH (I don’t why it doesn’t work the first time…) but I logged with the account pi which looks havn’t the permission to edit the config.yaml file… I try with root but it doesn’t work with password “raspberry” or empty…


#11

Use sudo instead. Like:

sudo nano /etc/astrobox/config.yaml

#12

Yeahh you rocks !

It’s works ! I can now connect to the printer, it’s a bit long maybe 15sec but finally the connection is established.


#13

Could you please tell me where to add the lines in config.yaml?
Should I add it to the existing “serial:” section, after the “port:” line?
Or is it at the bottom of the file, as completely new items?
btw, I tried both an my Astrobox wouldn’t load and I kept getting the “your atsrobox is still rebooting” message. If I remove the lines and restart it it loads.

Thanks


#14

I you already have a serial block then add it under it, starting with timeout. Make sure the indentation is right.


#15

I have connected my sigma printer to astrobox raspberry it did not connect then i clicked on log and it connected , i tried to take control of the printer it works up down but when you home the left extruder blocked against the bed do you have an idea please thanks


#16

regarding the modification listed upstairs that i did not do , where should we do this under astrobox thrue another software like putty or what your info for starter person is bit confusing

thanks