[SOLVED] DIY AstroTouch Screen faded color


#1

I have all of the components to build an AstroTouch Box, including license. I ordered the 3.5" screen recommended in the instructions. Once installed, the color on the screen seemed washed out/ faded, especially objects colored in red however greens look great. Thinking the screen was bad, I sent it back for a replacement.
The new screen looks very similar so I tried it on another Pi I have with the same result.
I am wondering:

  1. Are the screens bad?
  2. Is there something off in the software or drivers
  3. This is the way the screen looks and I just need to move on
  4. none of the above/ something else I didn’t consider

Any help would be greatly appreciated
Pic below is of my file screen, everything looks like a photo negative and the red is washed out. The circuit board screen saver looks great though


#2

Your colors looks inverted, I had this issue on my HDMI screen and I need to change resolution and color definition.
I guess that your screen isn’t HDMI one. try to follow information from this link: https://forum.astroprint.com/t/configure-astrobox-touch-with-cheap-3-5-tft-screen-rotation-and-inverted-colors-fixed/3825


#3

It could also be that you have a v2 version of the waveshare 3.5" screen but have configured your software for a v1


#4

Great suggestion thank you very much. I bet that is what the issue is. I did not notice that it was V2. Is it a problem if I change the driver after I have already booted it up? Instructions say to change before first boot. Thanks again, I really appreciate the help. I am new at this but really love the Astroprint products so I am trying to spread the word


#5

Thanks @Jonathan_Fisher!

If you can SSH into the box and are comfortable running some commands, you can update your screen without reflashing.

  1. Make the necessary changes to the astrobox-config.conf file as per instructions in step 6 here: https://astroprint.zendesk.com/hc/en-us/articles/360015968891-Flashing-AstroBox-Touch-Software

  2. SSH into your box and run these commands:

     $ sudo /etc/astrobox/initial-scripts/10-configure-screen
     $ sudo reboot
    

This should do it.


#6

I have just taken delivery of my V2.0 Waveshare 3.5" screen today and set it up. However, the screen is as described above. I have edited and SSH’d as above but it has made no difference. Can you please advise how to fix this issue. Thanks

Update: I used my origianl abt_3.5in_20180418.img image file to create the SD card. Will that make a difference. I have updated via the screen. If I now load the latest abt_3.5in_20180926.img file will it 1. fix the issue and 2. will I need new license files?

Thanks


#8

So, when I go to edit the astrobox-config.conf file it only conatins a single line

SCREEN_SIZE=35

So do I add an additional line with

SCREEN_DRIVER=waveshare35b_r2

or do I add it to the same line etc? Step 6 in the above file is not really specific in how or where to add these details.


#9

@Jonathan_Fisher - did you manage to resolve this issue with your v2.0 screen? I am still struggling.

Thanks.


#10

Thank you @Daniel. All working.

For anyone else with issues make sure you use the latest image to create the SD card. And then simply follow Daniel’s instructions above. Looks fab :slight_smile:


#11

I was able to edit the config file for the V2 screen however when I go to SSH into the box, the HDMI does not seem to be working. Is the HDMI output disabled for the touch? I have tried it on two different Pi’s using the same touch software sd card but both times the monitor says nothing is connected. As another check, I plugged my standard Astrobox (non touch) to the keyboard and HDMI and it displayed fine. So it only seems to be the Astro touch unit that is not displaying through the HDMI, any thoughts? Am I missing something? Do I just need to re-image the Touch unit? Thanks again for everyone’s help!


#12

You should SSH via network with the touch, it’s easier. Having said that we don’t disable HDMI but the raspberry pi software will if there’s not HDMI device connected on boot. Could that be it? Try booting the device with the HDMI monitor connected.


#13

I should have mentioned that I have been connecting the HDMI before booting with no luck. I have tried other combinations like booting with HDMI connected and with and without touchscreen connected with no difference. I looked though the config file to see if there was something that might be affecting the HDMI display but nothing jumped out at me. I tried comparing it to the config file from my other AstroBox but they are different enough that it wasn’t as effective as I had hoped.

I am fairly new to the software side of Rasberry Pi so I apologize but I am not familiar with using SSH though the network. I felt fairly confident in using the command prompt through the box however the HDMI not displaying has derailed that plan


#14

Once you have activated SSH as explained here (use option 2 since hdmi is a problem for you) you can simply go to the box’s IP address with a program like putty and you will see the command line.


#15

I will try that. Thank you very much again for the help, I really appreciate it!


#16

Okay, I was able to SSH into the Touch through the network (using putty). I typed everything you suggested and here is what I got:

Changing screen driver to waveshare35b_r2SCREEN_ROTATE=n (rotated:n)...
screen-config/change-screen-config.sh: 4: /screen-config/change-screen-config.sh: /screen-config/LCD-show-waveshare35b_r2SCREEN_ROTATE=n/LCD-show: not found
/screen-config/change-screen-config.sh: 5: cd: can't cd to /screen-config/LCD-show-waveshare35b_r2SCREEN_ROTATE=n
cp: cannot stat '/screen-config/LCD-show-waveshare35b_r2SCREEN_ROTATE=n/boot/config.txt': No such file or directory
Done! screen driver changed

The screen remains unchanged (colors still look bad) and I noticed the reference to LCD-show in the message above which was the solution I was pursuing before but never finished. I only got as far as copying the LCD-show-master folder onto the sd card and copying the config file. Previously I had removed the LCD-show-directory before trying your solution. After I got this message I added the folder back without any change in result. Did copying over the LCD-show-master folder affect the driver selection?


#17

Your astrobox-config.conf file wrong, you’re missing a line break. Use exactly this content inside your config file and re-run the commands:

SCREEN_SIZE=480x320
SCREEN_DRIVER=waveshare35b_r2
SCREEN_ROTATE=n

#21

ISSUE RESOLVED:
The solution that Daniel outlined earlier should work for everyone. It turned out that I had an issue with the program used to edit the config file (note pad in windows). Be aware that the link to the touchscreen in the list of Astrotouch materials is to the V2 of the screen and will require you to change the driver.
Many thanks to Daniel and the support team for their help and persistence to resolve my issue!