[SOLVED] Unable to start the WebRTC system video streaming?


#1

Hi I’m using a Logitech C615 webcam on RPi. I am currently able to take snapshots with the camera from AstroBox but when I try to start video streaming I get an error “Unable to start the WebRTC system”. Tried from both Chrome and Firefox browsers but get the same error. Wondering if anyone is able to help. Thanks


#2

I get very similar, see my post further down. Definitely a bug of some sort. I believe it’s an issue with the WebRTC software not being as up to date as it needs to be, probably a good reason for a company not to rely on someone elses product to keep there own product bug free imo. I believe this will be an ongoing problem off and on as long as WebRTC is a piece of the puzzle.


#3

Guys!

Sorry for this but there was a problem while upgrading our SSL certificate in our servers that affected our WebRTC system. WebRTC related errors should be fixed now


#4

I Daniel this is still an issue.


#5

It’s likely not the same issue. Maybe something with similar symptoms. What’s happening?


#6

I am also having the same issue, I can take snap shots of the print all day but as soon as I try to take video I get the error Unable to start the WebRTC system. I replaced my webcam with one known to work to make sure that wasn’t the issue but I am still getting the error. I am using chrome if that helps at all.


#7

Hi, I also have the same problem of WebRTC crashing as soon as I try to start the stream. Taking pictures works fine. I’m using a raspberry pi camera v1.3.


#8

Hello same here, I’m able to take snapshot but totaly unable to start the rtsp server. I tried with Chrome, Chromium and Firefox, with raspberry pi cam, a logitech and a microsoft cam.

same issue :confused:


#9

We’re working and a few bug fixes and improvements to the camera system to make it more robust. Upcoming release 0.10 will contain those.

We need a few weeks to complete, test and let it out


#10

Any beta releases? Sign me up if so.


#11

hello i have same problem i can take photos but no video streaming
unable to start the webrtc system
ver: AstroBox-v0.9(5)
any help
thanks


#12

i have same problem with c170 camera …

strange this is . if i visit my box local and try to stream i get the error .

but if i stream from astroprint.com the camera works .


#13

I have this same issue with raspicam.


#14

See my answer here: Raspberry Pi Camera Support [SOLVED]

I think it’s relevant


#15

Yep. That appears to be the case. I think the lack of WebRTC support on iOS mixed with chrome being broken made me think it just didn’t work. Thanks!


#16

I’m still having this problem. I just received my AstroBox yesterday 5/4/17, and I set it all up, including plugging in my brand new Logitech C615. I changed video format to VP8, and the message preparing video comes up, but I never actually get video. Using H264 format, I get the Unable to start the WebRTC system. What should I do ?

I’m using an iphone 6s to control my Astrobox.


#17

@Lee_Reed live video won’t work on iOS yet. Chrome support is coming back when we release 0.10(8). Looking like this coming Monday (May 8th)


#18

I’m hopeful that in the next couple days, this update will be announced! I do run Chrome browser on my iPhone. Would that make a difference?


#19

0.10(8) is out now. iPhones won’t play WebRTC video, even on Chrome. It’s a limitation of the iOS system


#20

That’s disappointing. There are bound to be lots of iOS Astrobox purchasers out there. I didn’t see the iOS limitation before I bought. I thought that buying the kit and recommended webcam I’d be set for remote control, but my -phone- is the limiting factor.
I will test through my laptop browsers. Hopefully my MacBook won’t have a similar problem.