Unstable link to Ender3 new mainboard 4.2.7

I have used my Astrobox (RPi 3B) with my Ender 3 for 3 years without any problems. However, I have just upgraded the Ender 3 to the new 32bit silent mainboard. The Astrobox now keeps losing its USB connection to the printer. Usually it will connect ok at switch-on and usually lose the connection and freeze partway through the first or second layer of the print. If I go into the Astrobox settings it will reconnect, but too late for the print. Printer is fine from an SD card. The Pi has an official 2.5A power supply. The new mainboard has a micro USB connector rather than the mini USB on the original board, so I needed a new lead, but I have now tried several brand new leads and all behave the same. Has anyone else had this problem?

We have gotten a few reports about this. It appears that maybe the serial connection on those boars or the associated firmware isn’t yet stable.

Note that printing from the SD Card is a completely different path and can’t be compared.

Thank you Daniel,
Has anyone tried a firmware update? I was going to try but I appear to have the latest version installed . . . unless it is corrupted in some way.

I am not a pro by any means but I have a small fleet of Ender 3’s and Ender 3 Max – I had the same issue with both the 4.2.2 and 4.2.7 mainboards. The firmware on these is honestly problematic in other ways like how it constantly disconnects from Octoprint and also sends erroneous temperature data.

I have been running 5+ weeks with 0 disconnects or issues and the solution for me was to stop using the default firmware. I know this sounds daunting but I just compiled Marlin (2.0.x - always read the stability and bug reports), they have a default Ender Profile which works just fine, takes no time to compile. With the Ender boards you can just throw the generated firmware (bin) on an SD Card, and boot the printer - that easy. As an added bonus lots of other features and information displays that were missing or incomplete now work too…