Workflow issues with Meshmixer


I usually bring my models from my CAD package (Autodesk Inventor) into Meshmixer to plop it on the bed, align it to get it upright, and add support.

If I then slice it in Makerbot Desktop, my XG3 works great with Astroprint. If I’m on the local network.

Today I tried to print from work, but my STL out of Meshmixer was on it’s side. I had no way to rotate it. And I couldn’t upload an X3G. Stuck I was.

My employer blocks VPN.

Any tips for a workaround.

Why would the Astroprint slice that way?


At the moment we just don’t the functionality to rotate/move the object. This is coming but for now the system prints the object as is.

The rotation could be done in the design tool and exported as STL already rotated.


Well, Meshmixer updated today and for the first time I saw an option box to Flip Z-Y axis on import/export. May have missed it earlier.

That fixes it.


Over a year ago rotation was coming out. Obviously coming out was not soon.

I use solid work for design. How exactly do I rotate the design and export it as you describe as a solution?
I am not aware of this being a solution.
I chose Astroprint for my 3Dprinter because it looked good on paper but without being able to rotate items before print I have to use something else. It looks like development is way behind schedule.


This is fairly easy in most CAD packages…In scad you could import the STL and rotate with one line of code and export. Some slicers (like like slic3r) and other tools like Repetier Host and this website offer this feature.

For solid works I found this rotation tutorial online:

Maybe one of these will help…I do hope AstroPrint will offer this soon too.


Whenever I export from Solidworks, I too have the STL on its side in similar fashion. What I do to correct it is open the STL in MeshMixer and perform the following:

  1. (Sidebar)>Edit>Align>(Source:Base Point), (Destination: World Origin / Z-up), (Transformation: Translate and Rotate; no flip)
  2. same as 1, but substitute “Z-up” with “Y-up”.
  3. (if model is correctly rotated) File>Export

Depending on which direction your original STL was, you may need to try different axes (X-up) or use the flip option. The model should be automatically centered on the work area each time the command is used, so if you don’t see it, it is probably flipped underneath it.

As they say, your mileage may vary. This is simply what I use for my setup. I hope this helps in the meantime, and I also hope that this feature does come soon. I can agree it’d definitely be useful.