X axis off center


#22

Ok, here’s my problem so we can determine if I’m actually having the same issue you guys are. Using my Right Extruder only, my prints all start off a distance to the right that appears to be exactly the same distance between the left and right nozzles. This would lead me to believe that the right nozzle is extruding but the left one is being used for orientation. Since AstroPrint only uses the right extruder (at least that was the case when I started using AstroPrint,) I have not used the left one. If I get the time, I will attempt to pause/unpause a print and load/print from the left side and note my results. Thanks.


#23

Well, I am definitely surprised tonight:

  1. Pausing and unpausing (10 sec pause) restarted the print in the center. Maybe a GCODE for pause then unpause at the very start would help, but;
  2. I went searching for a way to switch to the left extruder and found this: https://forum.astroprint.com/t/this-might-be-stupid-but-how-do-i-choose-extruder/322. I tried to switch to T1 mulitple times by just adding the T1 gcode but could not get it to switch so I copied the entire start code to my printer profile and made it T0. Newly sliced prints now start at center.

I’m not sure if all the code is necessary but I will play with it as time allows. I am printing a small clip for PowerPole connectors to test a full print. Let me know what you guys figure out. Hope this helps.


#24

Walter that makes sense and just looked and it is exactly the same as mine. It seems the software update has switched the extruders

@daniel any ideas about this?


#25

I don’t really know what could be causing this at this point. It appears that it has to do with extruder selection.

It’s not the cura 3 update since this happened already before that. We have been a little busy with that but as things start to slow down, I’m going to look into this. I already gave it a try but the X3G output makes it a little harder to debug than straight GCODE.


#26

Any update or progress on this?


#27

Check out the comments on this post, the one linked and the response (post itself contains start/end gcode) …

http://disq.us/p/1rheq2p


#28

Not sure gcode is going to help in an x3g situation? Does the start code even work with x3g?


#29

As mentioned check out the comments, should take you straight there, it mentions offsets store by the firmware as possibly being the issue and checking on the printer itself.


#30

Not trying to be flippant but can the firmware change the settings itself? It worked fine at first then all of a sudden changed


#31

Just something I figured I would pass along to check.

The start/end gcode may also help as this earlier post from Daniel seems to indicate it does first create the gcode then convert to x3g.


#32

Will try it and see what happens. Just frustrated as astroprint is awesome and it’s going to be something stupid


#33

No doubt, I’ve been using it full time as my slicer since I found it. Not having it would be a total pain!